site logo
新規投稿
*オープンクローズ
 + 
#
thilmera project - forum
質問
[Closed] 「このアプリがシャットダウンを妨げています」が表示される
2023/03/08[4]TAKA
質問
[Closed] フル機能版かオフライン専用版かの確認方法
2023/02/17[4]小鳥遊柊
報告
[Closed] アプデしました
2023/01/27[4]りんりん
報告
[Closed] オンダイGPU数が変化しない
2023/01/27[6]falsehood
検証
[Closed] 設定の組み合わせによる表示の乱れ
2023/01/24[2]Funky
質問
[Closed] Official ZIPのHash sha256は正常ですか
2023/01/19[2]Hash sha256
報告
[Closed] サウンド設定について
2023/01/17[2]butterfly
不具合
[Closed] オンダイGPUが増える
2023/01/12[9]falsehood
テスト
[Closed] マザーボードの情報取得テスト 0b177 Rev3 DEV2
2023/01/08[0]Gakuto Matsumura - Developer
要望
[Closed] デュアルディスプレイ構成における表示位置の保持について
2023/01/04[2]retsam
報告
[Closed] 実効クロックを表示中に低負荷コアが非表示になり表示段数が上下します
2022/12/31[8]マークX
報告
[Closed] 0b177_Rev1 起動時にエラーメッセージが出て起動しないことがある
2022/12/31[4]cronos
要望
[Closed] サウンドアナライザー常時表示
2022/12/28[7]りんりん
不具合
[Closed] 0b176 Rev.1 DEV17 トッププロセスがWindows7で動作しない
2022/12/26[3]こぶん
不具合
[Closed] Ver0b177への更新でエラー表示、更新に失敗する
2022/12/26[2]cronos
不具合
[Closed] 0b177 Ryzen Masterからの値取得
2022/12/25[5]すのー
報告
[Closed] 0b176 Rev.1 DEV7軽いですね!
2022/12/23[12]minami
検証
[Closed] トッププロセスCPUのサイクル計算モード不具合について
2022/12/22[7]もりけん
不具合
[Closed] [0b176 Rev.1 DEV9] GPU関連数値の異常
2022/12/15[17]サボり人
要望
[Closed] ファンの稼働率のグラフ表示
2022/12/09[6]thil
*オープンクローズ
 + 
#
thilmera project - forum
[Closed] 質問 「このアプリがシャットダウンを妨げています」が表示される
#919
TAKA - 2156@4pe/5jKw 返信 2023/03/06 19:06
シルメラを常用しています。製作者様、素晴らしいアプリをありがとうございます。
表題の件ですが、Windowsをシャットダウン及び再起動する際に毎回「このアプリがシャットダウンを妨げています」のメッセージが表示され、原因はシルメラ7とのこと。私の環境が悪いのかと思い、Windows10からWindows11へ変更しクリーンインストール環境で試してみましたが同じでした。何が原因と考えられるでしょうか?宜しくお願い致します。

Gakuto Matsumura - Developer 返信 2023/03/06
報告ありがとうございます。

うーん、その症状は初めて聞きます。
使用しているバージョンとエディション(64,s64,64arm,s64armのどれか)
あと再現されるthilmera7.iniファイルをここにアップロードしてください。
こちらで再現できるか試してみます。

TAKA - 2157@PPwZ21/ZZflwPPfm1wfmlPwXgmtJGZf2 返信 2023/03/06
お世話になります。バージョンは、0b177Rev.3です。s64を使用しています。thilmera7.iniをアップロード致しましたので、ご確認お願い致します。

[appended] ini

Gakuto Matsumura - Developer 返信 2023/03/07
テストしてみましたが、かなり限定的に一瞬だけシャットダウン時に終了待ちでひっかかる程度でした。

ただ、安全面への配慮により、終了に時間がかかっている問題があったので、そこの再調整と、ウィンドウへのクローズメッセージや「ALT+F4」でもプログラムを終了するなど、いくつかの変更をしてみました。

repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20230307-204947.zip

こちらのテスト版で確認してみて、それでも起こるか、改善されるかを試してみてほしいです。

TAKA - 2156@4pe/5jKw 返信 2023/03/08
ご対応ありがとうございます。さっそくテスト版で検証してみました。
Windowsの終了時に毎回症状が出ていましたが、テスト版に書き換えたところ症状が改善致しました。20回程、起動と終了を繰返し検証してみましたが問題ないようです。

取り急ぎ、ご報告致します。ありがとうございました。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 質問 フル機能版かオフライン専用版かの確認方法
#918
小鳥遊柊 - 2153@PPwZl1PwltwPP/XwlXmuu1t2PgfX1Pm 返信 2023/02/16 10:47
フル機能版とオフライン専用版のどちらで起動しているのか確認する方法はありますか?なお、検索しようとしたら”405 Method Not Allowed”と出てしまい検索できませんでした。

Gakuto Matsumura - Developer 返信 2023/02/16
>検索しようとしたら”405 Method Not Allowed”
上記修正しました。

>フル機能版とオフライン専用版のどちらで起動しているのか確認する方法はありますか?
メインウィンドウの属性情報が有効の場合は、左に THILMERA 7 S と表示され、オフラインの場合は THILMERA 7 N と表示されます。
属性情報が有効ではない場合、オフライン版では、反転色で thilmera is offlineと常に表示されます。

小鳥遊柊 - 2154@PPwZl1PwltwPP/Xt/P/t/ugJP0gZ/m0 返信 2023/02/17
ご対応・ご回答ありがとうございます。追加で質問えすが、”thilmera7_64.exe”や”thilmera7.exe”で起動しても”THILMERA 7 S”になるのですが、オンライン版を起動させたあとにオフライン版にするには何か設定等が必要なのでしょうか?

Gakuto Matsumura - Developer 返信 2023/02/17
>直接オフライン版(旧ノーマル版)を起動したい

インストーラーまたはアップデーターによりショートカットが作成されている場合は、末尾に(offline)がついているものから起動します。
ショートカットが生成されていない場合は、32bit環境ならば thilmera7.exe。AMD64環境ならば thilmera7_64.exe。ARM64環境ならば thilmera7_64arm.exeのショートカットを作成し、パラメーターに offline を追加してください。
これらの作業が必要な理由は、2022年に完全フリーウェア化をした際に、既存ユーザーがサービス登録のプログラムとしていて削除できなかったため、オフライン版として一応残してはいるものの、現在は7sが使用されることを前提に設計しているからです。
将来的にオフラインモードは7sに統合される予定です。


Q&Aに追加しておきました。

小鳥遊柊 - 2155@PPwZl1PwltwPP/XwfGGm1gZwPX0wJ2m 返信 2023/02/17
うまく起動しました。ご回答ありがとうございました。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 報告 アプデしました
#913
りんりん - 2115@wPwZZXtmPwu/PP1l2mGfltutuJ/1GmGX 返信 2023/01/25 18:27
・先程DEV8にアプでしたのですが、サウンドアナライザーの統計表示?って1つだけ表示されてましたよね?(記憶違いでしたらすいません)片方だけに表示させたいのですが設定項目を追加していただくことは可能でしょうか?(「統計表示」という設定項目では2つ消えてしまいます)

Gakuto Matsumura - Developer 返信 2023/01/26
うーん、片方だけですか。
スペクトログラムとスペクトラムを両方表示している場合ですよね。

両方を表示している場合は、前と同じスペクトログラムにのみ表示する仕様にするとかでもよければ。

それこそ馬鹿正直にそれぞれに表示のオンオフ設定を作ることは可能ですが、おそらく設定がさらに見づらくなりそうです。

りんりん - 2115@wPwZZXtmPwu/PP1lGwwZtG1g2PXfmZgu 返信 2023/01/26
>スペクトログラムとスペクトラムを両方表示している場合ですよね。
はい。

>両方を表示している場合は、前と同じスペクトログラムにのみ表示する仕様にするとかでもよければ。
ぜひそれでお願いしたいです

Gakuto Matsumura - Developer 返信 2023/01/27
こちらそのようにしたので、次回以降に適用されます。

りんりん - 2115@wPwZZXtmPwu/PP1l/fXJZ00X2Xt2Zfu 返信 2023/01/27
ありがとうございます!!

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 報告 オンダイGPU数が変化しない
#914
falsehood - 2148@GTwLo0Vu 返信 2023/01/26 14:04
先日、GPUが多いとご報告した者です。
あの時使用した試験用プログラムでは確かにGPUが一つになりましたが、現在Thilmera最新版では、アップデートのお知らせの「0番を無視」によってGPUが減っておらず、二つ表示されたままとなっています。

Gakuto Matsumura - Developer 返信 2023/01/26
配信チャンネルによって最新版は異なるので、0chのDEV8でのことでしょうか?
1chにもお知らせを入れていますが、デフォルトの1chにその変更は適用されていません。

りんりん - 2115@wPwZZXtmPwu/PP1lGwwZtG1g2PXfmZgu 返信 2023/01/26
0chです、

Gakuto Matsumura - Developer 返信 2023/01/26
ならば前回の修正は結局役に立っていないということなので、ログをとりながらの確認からもう一度お願いします。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20230126-175301.zip

りんりん - 2115@wPwZZXtmPwu/PP1lGwwZtG1g2PXfmZgu 返信 2023/01/26
>0chです、
大変申し訳無いです、別の方のところに返信してしまいました、、、
ほんとにすいません。。。

Gakuto Matsumura - Developer 返信 2023/01/26
おおぅ、私も確認が不十分でした。
すみません。

Gakuto Matsumura - Developer 返信 2023/01/27
>falsehoodさん

とりあえずこの問題ですが、1ch(デフォルトから変えてない)ならば、0chでの話なので、1chの最新版はまだ12月リリース分となります。
ひとまず「重要なお知らせ」の文面の方は、0chのお知らせですという事を明記しておきました。

もし0ch(DEV8)にしているけど以前の問題が直っていない状態が復活している。という場合はテストをお願いします。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 検証 設定の組み合わせによる表示の乱れ
#912
Funky - 2152@fj8WJCta 返信 2023/01/21 02:55
・ハードウェアアクセラレーション:ON
半透明ウィンドウが選択できない

・ハードウェアアクセラレーション:OFF かつレイヤード:ON
文字や全体的な色合いがくすむ(透明度の値に関わらず透けているから?)

0b177 Rev.3 初期状態から
フォント:@07x11AA カラー:monoToneBlack 温度カラー:ON
にして試しました

Gakuto Matsumura - Developer 返信 2023/01/21
>半透明ウィンドウが選択できない
バグではなく、現状再現できないことと、とくに必要性がないだろうということでこうなっています。

>文字や全体的な色合いがくすむ(透明度の値に関わらず透けているから?)
ハードウェア描画を基準にしたらそうなりますが、これがもともとの標準です。
全て完全なメモリ上の計算にて行っているので、これも乱れているわけではありません。

Gakuto Matsumura - Developer 返信 2023/01/24
>半透明ウィンドウが選択できない
半透明ウィンドウの件ですが、さきほど0chにて、ハードウェア描画における「半透明ウィンドウ」および「背景の透明化」対応版を配信開始しました。

ハードウェア描画は負荷軽減のためにかなり複雑な作りなので、トータル40時間くらいかかったかもしれません。
やっとできました!

>文字や全体的な色合いがくすむ(透明度の値に関わらず透けているから?)
ソフトウェア描画のレイヤードは、RGBAを32bitの数値で指定するのですが、奇妙なことに、128,255,255みたいなRGBを50%の透明度にしようとすると、アルファが128で、64,128,128みたいな、RGBをアルファの割合に減らした数値にしないといけない、という奇妙なルールがあるので、発色やアルファブレンドがハードウェア描画に比べて正確ではない点については現状の知識ではこれがベストのもの、という感じです。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 質問 Official ZIPのHash sha256は正常ですか
#911
Hash sha256 - 2151@gziI3HF9 返信 2023/01/18 05:55
Official ZIPは a0b036ac4f6008f4bedaea7de7edb533c45ac53c0d65698ca735145f98a3bba2
sha256ZIPは 4D67A84BF20405E3088382C4CD2033579964C6E3F535CD188C510A2CBA35C2C5
でした。
今は更新をやめているのでしょうか

Gakuto Matsumura - Developer 返信 2023/01/18
報告ありがとうございます。

調べたところ、ハッシュを計算するプログラムに、対象のファイルのサイズが一部の条件になると、余白の0埋めデータをハッシュ計算に含めてしまうバグがありました。

初期の目視による確認を行った際のファイルサイズでは問題なく一致していて、現在でも問題のあるものとないものが混ざっていた状態だったようで、問題を認識していませんでした。

ご指摘いただけて助かりました。ありがとうございます。

Hash sha256 - 2151@gziI3HF9 返信 2023/01/19
直っているのを確認しました。よかったです。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 報告 サウンド設定について
#910
butterfly - 2149@+nqc4paE 返信 2023/01/15 17:34
報告と質問をさせてください
・マスターボリューム表示の値が音が流れている間しか同期されません
・スペクトログラムでは右上隅に小さく出力情報が表示されていますがこの情報はスペクトラムでは表示できないのでしょうか?

単なる設定ミスでしたら申し訳ありません

Gakuto Matsumura - Developer 返信 2023/01/15
テスト版にて、以下の変更をしました。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20230115-231514.zip

● サウンドアナライザー, stage1
 ・マスターボリューム値を、レンダーなしの無音時でも更新されるように修正。
 ・ボリュームの表示欄に、ミュートの状態を追加。
 ・ボリュームとミュートの取得をコールバックに変更し、負荷を軽減。
 ・次回分の音声データを待つ際のシグナル待機を改善。
 ・「無音+入力音声」の際に意図しない待機時間が発生していたのを修正。
 ・音声データのヘルツ数などの情報を、スペクトラムの方にも記載。表示するかどうかの選択肢を追加。

butterfly - 2150@+nqc4paE 返信 2023/01/17
ありがとうございます。頂いたファイルで正しく作動しています。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 不具合 オンダイGPUが増える
#909
falsehood - 2148@e1qilgGU 返信 2023/01/10 11:02
お初に失礼します。
以前より、使用しているマシンのCPU内蔵グラフィックが二つ表示される、と言う状況が発生しておりました。
直近の更新で遂に三つに増えました。
添付画像の通りです。
使用マシンはSurface Pro 3、CPUはi7-4650Uです。
DXGI-Pモードでは一つ目のGPUのみ使用率が変動し、下二つは0%で固定されます。
DXGI-Pのチェックを外すと三つが連動して動きます。
コマンドプロンプトより可能なシステム修復は試みましたが変更ありません、Surfaceは全てのドライバーが自動更新によって当たる仕様になっている為ドライバー不良も考え辛いです。
ワット数、周波数が表示出来ないのは恐らくGPUがその情報を提供していない為だろうと思いますが、増えてしまうのは原因が分からなかった為、ご報告します。
既出でしたら申し訳ありません。

Gakuto Matsumura - Developer 返信 2023/01/10
なるほど。gpu-Iの2~3は本来ないもののはずですよね。

こちらのテストで出される、"debug_log.GPU.txt"というファイルをここに添付してほしいです。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20230110-173033.zip

Gakuto Matsumura - Developer 返信 2023/01/10
手持ちのIntel HDの古いノートを引っ張りだしてきましたが、正しく1つでした。
何かしらの対処が必要なのだと思いますが、ログでGPUの識別がそもそもどうなっているか確認したいです。

falsehood - 2148@BS3Hqiem 返信 2023/01/11
お返事ありがとうございます。
頂いたファイルで実行した所、3つ目は出現せず、GPUが二つ表示されている状態でした。
以下にファイルを添付致します。

[appended] txt

Gakuto Matsumura - Developer 返信 2023/01/11
まず、データからわかることは、IDの異なるGPUが二つ検出されていること。
DXGIpの収集を確認したところ、複数GPUでのマッチングに失敗していそうなこと。

まずはDXGIpの問題の修正を試みてみました。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20230111-020737.zip
これでDXGIpにて、二つ目のGPUが0%で固定される問題が解決されるか確認をお願いします。

もしそれが問題なければ、続いて1と2が全く同じ数字か、もしくは別の数値を示すかの確認をお願いします。

Gakuto Matsumura - Developer 返信 2023/01/11
あ、すみません、今検討したら、これは多分結果が変わらないようです。

こちらでとりあえず、「Intel(R) HD Graphics」が含まれる2つめ以降を無効スロットにするように組んでみましたが、ある意味根本的な解決になってません。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20230111-022352.zip

Gakuto Matsumura - Developer 返信 2023/01/11
こちらのテストにて、前回と同じく"debug_log.GPU.txt"というファイルをここに添付してほしいです。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20230111-023633.zip

手持ちのIntel HDと比較して、予想ではありますが、ハードウェアの番号がすべて0番となっているもの(おそらくCPUのダイ)を除外するようにしてみました。

falsehood - 2148@e1qilgGU 返信 2023/01/11
三つ添付頂いた内、最後の一つで出力したファイルを添付致します。
表示としては、GPU表示が一つだけになりました。

[appended] txt

Gakuto Matsumura - Developer 返信 2023/01/11
ありがとうございます。
こちらの意図通りにはなったようですが、falsehoodさん的にはこれでよさそうですか?

falsehood - 2148@e1qilgt6 返信 2023/01/12
はい、配置もすっきりし、見易くなりました。
次回更新以降、これでご対応頂けると助かります。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] テスト マザーボードの情報取得テスト 0b177 Rev3 DEV2
#908
Gakuto Matsumura - Developer 返信 2023/01/08 18:52
0ch にてIntel Z590などに使われているマザーボードの情報取得テストを実施中
レポートのマザーボード情報にて以下のチップIDとなるもの
D440(1), D592, C732
その他テスト
D802, 8631, 8689, 8695

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 要望 デュアルディスプレイ構成における表示位置の保持について
#907
retsam - 2147@uPwZP1ZPfmXPPtfJGXZl/Xl2mtwlG/w 返信 2023/01/03 23:32
当方、Windows11 22H2において、DP接続によるメインディスプレイと、HDMI接続によるサブディスプレイ構成で使用しており、Thilmeraはサブディスプレイ側に表示させています。このとき、サブ→メインの順でディスプレイの電源をOFFにし、再び両方ONにした場合、Thilmeraの表示がメインディスプレイ側へ移動してしまいます。サブディスプレイ側への表示を保持出来ないでしょうか?
Windows側の設定である"モニタの接続に基づいてウィンドウの位置を記憶する”はONにしてあります。

Gakuto Matsumura - Developer 返信 2023/01/03
DisplayPort接続のモニタの電源を切るのは多くのソフトウェアの配置を狂わせるので、基本的には画面外に出て見えなくなってしまっても補正しないなどの設定にする必要があります。

まず「サブロック」というのをオンにして維持できないかを試してみて下さい。
それでも無理な場合は追加で「位置補正」をオフにしてみてください。

どちらかで可能ならば結果を。両方やっても無理ならそれはそれで教えてください。

retsam - 2147@uPwZP1ZPfmXPPtfJGXZl/Xl2mtwlG/w 返信 2023/01/04
位置補正とサブロックを両方ともオンにした場合、サブ側に保持されるようになりましたが、元々画面の左上に表示させていたものが右下に移動してしまいます。
サブロックのみオンにした場合、画面の左上に保持されるようになりましたが、メインの電源のみをオフにした場合(サブ側にメインが移った場合)、Thilmeraの表示が消えてしまいます。
私の使用環境ではこれでも特に問題はありませんので、サブロックのみONの設定で使用します。ありがとうございました。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 報告 実効クロックを表示中に低負荷コアが非表示になり表示段数が上下します
#906
マークX - 2146@wPwZPXtmP/XfPP1fgGwwGuf2XgGXfZJ 返信 2022/12/30 20:19
お久しぶりです。
3900Xから5900Xへ換装したところ、殆ど負荷が掛からない状態になると添付のgif画像のように非表示再表示を繰り返すようになり、そのタイミングでCPUより下の表示が全部上下するようになってしまいました。
再現のため設定ファイルを削除してryzenマスター使用にチェックを入れ、2021年版ドライバ使用のチェックを外した状態となっております。

Gakuto Matsumura - Developer 返信 2022/12/30
ちょっとこちらのデバッグ版にて、そもそもデータの数が変動しているかを確認してほしいです。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20221230-204057.zip

一行上にDEBUG sz* cpusz* などの数値がでるので、そもそもその数が変動しているかどうかの確認をお願いします。

マークX - 2146@wPwZPXtmP/XfPP1fgGwwGuf2XgGXfZJ 返信 2022/12/30
szとcpuAEszの値は変動しています。
あと、書き忘れましたがこの5900XはB2ステップと呼ばれる後期製造モデルのようでした。

Gakuto Matsumura - Developer 返信 2022/12/30
多分ですが、無効データ扱いにしていた0hzという状態になるようになったのだと思います。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20221230-212635.zip

こちらで確認をお願いします。

マークX - 2146@wPwZPXtmP/XfPP1fgGwwGuf2XgGXfZJ 返信 2022/12/30
非表示と再表示は無くなりましたが、存在しないコアが表示されるようになりました。

Gakuto Matsumura - Developer 返信 2022/12/30
やはりだめか~

ちょっとこちらで再テストをお願いします。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20221230-214309.zip

マークX - 2146@wPwZPXtmP/XfPP1fgGwwGuf2XgGXfZJ 返信 2022/12/30
szとcpuAEszの変動が無くなり、コア数が12で非表示再表示も発生していません!

Gakuto Matsumura - Developer 返信 2022/12/30
ありがとうございます。
とりあえずMS Storeへの更新がまだだったので、ちょっと頻度多めになってしまいましたが、Rev.3として全体更新し、今年最後のアップデートとして〆ました。

マークX - 2146@wPwZPXtmP/XfPP1fGl0Xl2GG/lmZ/ZX2 返信 2022/12/31
迅速な対応ありがとうございました!
来年もよろしくお願いいたします。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 報告 0b177_Rev1 起動時にエラーメッセージが出て起動しないことがある
#905
cronos - 2144@PPwZP1Pw2twfPP0JwfXZu0JXglmZJ2t1 返信 2022/12/30 10:35
いつもお世話になっております。cronosです。
前回対応頂きました0b177 Rev1を利用させて頂いております。
自動起動設定を有効にして、PC起動時にthilmera7を立ち上げるようにしているのですが
今回初めて起動に失敗したので共有します。

エラー発生時、 "Can't write config file!"とのエラーが出ました。
その後アイコンをクリックして手動で起動した時はいつも通り問題無く起動しました。
windowsシステムが入っているCドライブ(SSD)とは別のディスク(HDD)にthilmera7を入れております。

Gakuto Matsumura - Developer 返信 2022/12/30
設置している場所のiniファイルが、管理者権限でも書き出しできない場合、そのエラーになります。

とくにそのあたりは変えていないので、環境によるものかもしれません。

thilmeraのスタートアップサービスということですよね?

再現されたWindowsのバージョンを教えてください。

Gakuto Matsumura - Developer 返信 2022/12/30
あと、再現性はどの程度ありますか?

滅多にないが再現される、か
よく再現される、か
必ず再現される、か

Gakuto Matsumura - Developer 返信 2022/12/30
とりあえず先行してRev.2にて、0.5秒間リトライするようにしておきました。

これでも出るかどうかの確認や頻度の確認と報告をしていただけると助かります。

cronos - 2144@PPwZP1Pw2twfPP0JwfXZu0JXglmZJ2t1 返信 2022/12/31
反応遅くなりました。
windows10(x64)のバージョンは21H2、OSビルドは19044.2364です。
再現性は今の所無いようです。 過去にも出た事はなく、報告時が初めての遭遇でした。
珍しいものを見たので報告表示でご連絡でしたー

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 要望 サウンドアナライザー常時表示
#903
りんりん - 2145@wPwZZXtmPwu/PP1lG1GXPuPGuwluwtm 返信 2022/12/27 16:22
月齢をお願いしたものです。お世話になっております。
今回は月齢とは関係ないのですが、要望です。サウンドアナライザーを無音のときに消さないような処理にしてほしいです。僕は一番下に表示させてるんですが無音になると下が空白になってしまい物足りなくなってしまうのが少し残念です。(背景は表示されています)よろしくお願いします。

Gakuto Matsumura - Developer 返信 2022/12/27
無音になると空白になるのは前のバージョン(0b176)にて対処しましたが、それ以降でも起こるということでしょうか?

りんりん - 2115@wPwZZXtmPwu/PP1lG1GXPuPGuwluwtm 返信 2022/12/27
現在最新バージョン(0b177 Rev.1)です

りんりん - 2115@wPwZZXtmPwu/PP1lG1GXPuPGuwluwtm 返信 2022/12/27
.iniのこと忘れてましたどうぞ

[appended] ini

Gakuto Matsumura - Developer 返信 2022/12/27
ありがとうございます。
こちらで再現できたので、修正してみました。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20221227-171109.zip
テストをお願いします。

りんりん - 2115@wPwZZXtmPwu/PP1lG1GXPuPGuwluwtm 返信 2022/12/27
ありがとうございます!無事修正確認できました!
ただ、初回起動時や再起動時にここの表示は消えたままなので正式配布時には修正してもらえると嬉しいです!

Gakuto Matsumura - Developer 返信 2022/12/28
khzなどのゲージは、現状元となる音声データが来た時の内部で位置計算をしているので、そもそも再生されていない場合も表示するとなると、ちょっと根本的な手直しが必要になります。

とりあえずToDoには入れておくので、可能であればいずれ対応します。

りんりん - 2115@wPwZZXtmPwu/PP1l2u2tJl/Jm1/1JtgJ 返信 2022/12/28
そのような仕組みになっていたんですね
思ったんですけどあんまめったに再起動しないんでこのままでもいいかもです。w
ささとさんにおまかせします

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 不具合 0b176 Rev.1 DEV17 トッププロセスがWindows7で動作しない
#899
こぶん - 2142@O9v8GTdl 返信 2022/12/24 20:11
Windows7 Pro SP1 32bit にてトッププロセスのすべての項目が描画されず行数分が空欄になりました。このときservices.exeがコア一つ分のCPUをしていしまた、すべてのトッププロセス系の項目をOFFにするとservices.exeのCPU利用率は1%以下でした。
また、トッププロセス系の項目のいずれががONの場合にレポート:リアルタイムプロセス詳細情報またはレポート:リアルタイムTCP-UDP情報を選択するとレポート画面が黒一色になりフリーズしました。
サイクル計算モードのチェック有無に関わらず上記の状態が発生しました。
なお、Windows7へはリモートデスクトップで接続しており、ローカルデスクトップでの状況は確認していません。
平日日中以外はWin7機は触れませんので、自宅にもWin7環境を作成して追試できる状態を用意するつもりです。

Windows 10 Home 64bit, Windows 10 Pro 64bit, Windows 11 Pro では正常に動作しています。

Gakuto Matsumura - Developer 返信 2022/12/25
報告ありがとうございます。

確認した問題を3点ほど修正しました。
DEV19になります。
結局25日になってしまったが、リリース前に気づけてよかったです。
ありがとうございます。

こぶん - 2142@O9v8GTdl 返信 2022/12/25
Hyper-V上のWindows 7 Enterprise SP1 32bit US版( developer.microsoft.com/en-us/microsoft-edge/tools/vms/ からDLしたVM) でトッププロセス系の項目、レポートが動作することが確認できました。
実環境へのWindows7 SP1の導入はOS発売時点のメディアのため証明書有効期限の関係でWindows Updateができず、行えませんでした(Update Catalogueから証明書を更新するKBをインストールすればできそうだですが諦めました)。明日にでも症状を確認した環境でDEV19を導入して確認します。

こぶん - 2142@O9v8GTdl 返信 2022/12/26
Windows7 Pro SP1 32bit におけるトッププロセス系の表示によるフリーズが version 0b177 で解消されていることが確認できました。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 不具合 Ver0b177への更新でエラー表示、更新に失敗する
#901
cronos - 2144@PPwZP1Pw2twfPP0J1P2gwmuXPPJ1mgll 返信 2022/12/26 00:33
毎日大変有り難く使わせて頂いています。
25日深夜にVer0b177にアップデートする操作を行ってから、アップデーターがエラーを出して
アプリケーションの起動まで辿り着かなくなってしまいました。

>[2022 12/25 23:23.33] 開始しています。
>[2022 12/25 23:23.33] サーバーに接続しています。
>[2022 12/25 23:23.34] thilmera7のサービスを停止しています。
>[2022 12/25 23:23.34] Ver0b176 Rev.1 -> Ver0b177
>[2022 12/25 23:23.34] データをダウンロードしています。
>[2022 12/25 23:23.35] データを展開しています。
>[2022 12/25 23:23.35] ■ バージョンが一致しません。 [ver/pac]
>[2022 12/25 23:23.45] ■ アップデートは中断されました。
>[2022 12/25 23:23.45] ■ アップデートに失敗しました。

OSはWindows10、CPUはCorei7-4790Kです。
webサイトにて公開されております、thilmera7 updater (Ver0.6.13.0)を利用して
最新リリース(0b177)を選択してダウンロードした場合も同様に、バージョンが一致しませんと言われアップデートが進みませんでした…

Gakuto Matsumura - Developer 返信 2022/12/26
報告ありがとうございます!

ファイルのアップデート順序により、最新の0chが更新された後にアップロードされた1chのバージョン番号が更新対象とみなされなかったようです。

とりあえず更新を走らせておきました。

ちょっとこの問題の再現がおこらないように仕様をみなおします。

cronos - 2144@PPwZP1Pw2twfPP0J1P2gwmuXPPJ1mgll 返信 2022/12/26
ご対応有り難うございます!
再度updaterを起動したところ、問題なく1chを使って0b177にアップデートする事に成功しました!

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 不具合 0b177 Ryzen Masterからの値取得
#900
すのー - 2143@PPwZZ1PwZ/lPPu0Z2PGXJlfguuJfG1t 返信 2022/12/25 21:09
0b177にアップデートしたところ、CPUメイン行に表示されるRyzen Masterからの値(温度、クロック、PPT、電圧)が表示されませんでした。
フレーム速度をプリセットから10fpsまたは20fpsに設定すると表示されるようになったため、更新フレーム頻度-温度系を1から2にしたところ、表示されるようになりました。
値の更新は設定値通り2回毎に行われています。

Gakuto Matsumura - Developer 返信 2022/12/25
報告ありがとうございます。

すみません、再現されたのはどんな設定なのでしょうか?
再現されるiniファイルを頂けると助かります。

例えば現行、フレームの最速は16ms。
この場合、設定最速の温度系などは計算上2以下の設定にはなりません。

上限設定を無視して16msの1更新にしてみましたが、とくに表示されないということはありませんでした。

すのー - 2143@PPwZZ1PwZ/lPPu0w10twZwG2GuZ2uGu 返信 2022/12/25
情報を毎フレーム更新して欲しかったので、プリセットから5秒を選んだ後、基本の更新間隔を500msにしていました。
0b177では同じように設定するとCPUメイン行のRyzen Master情報のみ取得ができません。
この状態の設定ファイルを添付いたします。

[appended] ini

Gakuto Matsumura - Developer 返信 2022/12/25
ありがとうございます。

こちらでテストをお願いします。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20221225-221750.zip

すのー - 2143@+Fkeo0Wu 返信 2022/12/25
テスト版問題なく動作しました。アップデート前と同じように毎フレーム取得できました。

Gakuto Matsumura - Developer 返信 2022/12/25
ありがとうございます。
Rev.1に更新しました。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 報告 0b176 Rev.1 DEV7軽いですね!
#896
minami - 2136@0PwZg2gXwPPlXlP20tu1fX1ZXguX 返信 2022/12/13 22:04
いつもお世話になっております。
お知らせを見て、負荷が軽くなったとの事で試してみたい思いに逆らえず、試してみました。
CPUはRyzen 3600、シルメラはソフトウェア描画、固定時間待機OFF、並列化OFF、EcoQoSは無効です。
私はアイドル時の電力消費を抑える為、シルメラのフレームレートは1fpsにしておりました。
20fpsにすると、アイドル時にCPUが19W強、1fpsで11W強、それ以上遅くしても有意な変化は
見られないので1fpsにしておりましたが、0b176 Rev.1 DEV7では20fpsにしても12.1W、1fpsで10.6Wと劇的な変化が見られました。添付のSSは1fps時のものです。残念ながら比較元のバージョンは覚えておりませんが、表示項目やレイアウト等は当時より変更しておりません。素晴らしい改善ぶりにちょっと感動を覚えました。ありがとうございます!

私には並列化のON/OFFによる違いは体感出来ず、20fps時にシルメラ上の負荷数値を見てもほんの僅かに並列化OFFの方が数値が小さいかもしれないという感じなので処理が速いならば並列化ONが良い様に思いましたが、Winタブ等のキャッシュが小さいCPUでは並列化する事でキャッシュアウトが発生するコアが増えるなら無効が良いのかな、という印象も持ちました。

Gakuto Matsumura - Developer 返信 2022/12/13
ありがとうございます!

並列化に関しては、それぞれのデータ取得などで待たされる時間は、必ずしもCPUタイムによるものとは限らないので、同時処理することにより、取得から表示にかかる時間を短縮するのが目的ですね。

なるほど。
キャッシュアウトに関しては、今回の並列化とは別に、そもそも別スレッドにしないとめちゃんこ時間がかかるRyzenMasterやトッププロセスやSMARTなど、結構多くのスレッドが元から別枠で動いているので、この辺もしかしたらシルメラで使用するコアを基本一つに束ねる設定とかあるといいかもしれませんね。

シルメラで使用するCPUコアをすべて同じに設定すれば、今回の並列化でキャッシュアウトというのも対処できそうな気がします。

ただ、IntelのCPUのハードウェア情報などはそもそもそのコアでしか取れないので、ここはどうしようもない感じですが。

minami - 2138@0PwZg2gXwPPlXu/2/0lXmlJtZwm/Z 返信 2022/12/22
なるほど、並列化の目的はそういう事だったんですね。確かにRyzenMasterなんかかなり時間かかりますよね。理解できました!

コア指定については使用コアを束ねれば敏感なクロック制御設定だとクロックが上げられて一見アイドル電力が僅かにあがるかもしれませんが、キャッシュアウトの頻度が抑えられてパフォーマンスの低いCPUではパフォーマンスの落ち込みが減る、といったイメージですが、ATOMの様な非力なCPU向けの思索ですし、とりあえず起動時のaffinity maskの指定やタスクマネージャからのコア指定変更でテスト可能ならお休みの時に少し試してみたいと思います。

話はかわるのですが、Ryzen3600機にDEV14が降りてきまして、DEV13からアップデートしたところ、私の利用範囲では問題は見られなかったので、GeminiLake機でシルメラのメニューで「再起動」を選択し、こちらもDEV13からアップデートしたのですが、再起動後シルメラの表示が縦に縮みました。よく見るとGPUトッププロセスとページファイル表示が無くなっていました。設定は先日SSを張り付けたRyzen機と同じで、シルメラ本体のファイル群があるドライブレターやフォルダ名も同じです。Ryzen機で問題が見られなかった為、DEV13をバックアップせずにアップデートしてしまい、再現テストが出来ずに申し訳ありません。別スレに書くべきだったかもしれませんが、再現テストが出来ず、所謂おま環というやつかもしれないので一旦こちらに書かせて頂きます。

Gemini Lake機の方のシルメラ設定を見てみると、トッププロセスGPUがOFFになっていました。こちらはONにすると即座にシルメラに反映されましたが、ページファイル設定はONのまま、シルメラ上では非表示になっていました。設定でON/OFFをトグルしてみても反映されないので、ONの状態でシルメラを一旦終了させ、改めて起動してみたところ、ページファイルの表示が復活しており、設定でページファイルをON/OFFすると即座に反映される様になっておりましたので、最終的には問題無いのですが、ちょっと不思議な事象でした。

Gakuto Matsumura - Developer 返信 2022/12/22
うーん、なんか再現性はないけど、アップデートしたときに変になったという報告が他でもあります。

念のため、問題が起こった機体で、thilmera7.upd.exeにて、1chを選んでrev.1に戻して起動し、その後0chに切り替えて更新して問題が再現されるかの確認をお願いしてもよいでしょうか?

minami - 2139@0PwZg2gXwPPlX0l1l20X1ltmtJfZg 返信 2022/12/22
こんばんは。
ご教示頂いた方法を試してDEV15にしてみましたが、問題は再現されませんでした!
念のためiniファイルも履歴フォルダから戻してもみましたが問題は再現されず、シルメラが縮む事はありませんでした。安心いたしました。

ただ、ページファイル表示のON/OFFトグル操作によるシルメラへの即反映については再現しました。ページファイル表示OFF設定で起動したシルメラでページファイル表示をONにしても、即反映されず、再起動する必要がありました。ページファイル表示ONで起動したシルメラではON/OFFが即反映されますので、処理軽量化でこうなったのかもしれないと思い、2chに接続して0b175に戻してみたら、どちらの設定でもON/OFFが即反映される様になりました。

Gakuto Matsumura - Developer 返信 2022/12/22
報告ありがとうございます。

発現したOSのバージョンの情報と、iniファイルをください。
>ページファイル表示OFF設定で起動したシルメラでページファイル表示をONに
こちら、初期設定などでも試してみましたが、こちらでは再現されませんでした。

minami - 2139@0PwZg2gXwPPlXPgfuJlwwtgu1Jtmw 返信 2022/12/22
すみません、Gemini lake機のエラーチェックもしていて遅くなりました。
iniをお送りしようとしたら、iniのサイズが小さく0b175のままになってる事に気付き、改めてDEV15にしたんですが…今度はページファイルも症状が再現されませんでした。これは一体どうした事かと思い、念のためシルメラのヘルプにあるWindowsコンポーネントのチェックをしてみましたが、エラーも無いので、もう一度ch1から0b176 Rev1にする所から始めると、ここで症状が出ました。同じように再度DEV15にしてみましたが、今度はページファイルがちゃんと即反映されるのです。ちょっとポルナレフ状態です(^^;
元々DEV13→15での症状だったんですが、再現しないので先ほど症状が出た0b176 Rev1で更に3回検証を繰り返して、3回とも1chから0b176 Rev1に戻した所で症状が出ましたので、そのiniをお送りします。OSはWindows11 Home 22H2 Build 22621.963です。
お手数をおかけしますorz

[appended] zip

Gakuto Matsumura - Developer 返信 2022/12/22
報告ありがとうございます。
現状、0b176 Rev.1 DEV14,15ではおこらず、1chの0b176 Rev.1だと再現される、ということでしょうか?

Gakuto Matsumura - Developer 返信 2022/12/23
即反映されないという点で、心当たりを修正しました。
DEV16にて再度確認をお願いします。

変えたのは、パーセンテージの値が変更されていない場合、全体更新されない限り描画内容を更新しない。という部分で、設定オフ時に0リセットするようにしました。

minami - 2141@0PwZg2gXwPPlXPgfuJlwwtgu1Jtmw 返信 2022/12/23
元々はGemini Lake機でDEV13→14に更新した際に気づいたのが切っ掛けでしたので14で起こらないとは言いづらいのですが、しかし何度も試行して再現できたのはおっしゃる通り、1chの0B176 Rev.1であります。

minami - 2141@0PwZg2gXwPPlXPgfuJlwwtgu1Jtmw 返信 2022/12/23
DEV16テストしてみましたが、更新後、ページファイルをON/OFFしてみたら即更新はされなかったのですが、先ほどのお話から描画内容の更新がされないという事でしたので、試しにすぐそばにある仮想メモリ表示をOFFしてみたところ、入れ替わる様にページファイルが表示されました!その後仮想メモリもONにすると、両方とも表示されたままになりました。
このままシルメラを再起動して色々試してみようと思ったらDEV17になっていましたw
DEV17では今のところ症状は出ておりません。

私はWindowsのページファイルを用途によって無効にして運用したりするのですが、先ほどのお話からするとこれは原因の一端になりますかね…(^^;

Gakuto Matsumura - Developer 返信 2022/12/23
すみません、DEV16ではゼロリセットだったのですが、オンにしたときに使用率0%だったら意味ないじゃん!
と思ってDEV17ではマイナスリセットにしました。

ページファイルの使用率はソフトによるのですが、元々最近のOSでは、正確にはページファイルはメモリ上のキャッシュを完全に使い尽くすまでは0%の状態なので、オンにしたけど、0から0だと変わってないから、描画する必要なし。として表示に適用されなかったのではないかと思います。

25日までの間、しばらくDEV17で様子を見ていただけると助かります。

minami - 2141@0PwZg2gXwPPlXPgfuJlwwtgu1Jtmw 返信 2022/12/23
遅くまでありがとうございました!とても納得できる最適化に感謝であります!
ありがたく、様子を見てみようと思います。
ごゆっくりお休みくださいませ…おやすみなさい!

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 検証 トッププロセスCPUのサイクル計算モード不具合について
#898
もりけん - 2140@Jh1MSsFH 返信 2022/12/22 20:42
お疲れ様です。有り難く使用させて頂いております。
トッププロセスCPUのサイクル計算モードON時に
トップ1だったプロセスがCPU使用0%になっても、
トップ1に残ったままになる現象が発生しています。
(ほぼ永久に残る、何かのタイミングで消えることもあります)

添付画像の上がプロセスフル稼働時、下が0%時になります。
画像のプロセスYaneuraOu_NN-7503.exeの場合に良く起きます。
(0%時は、全スレッドがWaitForSingleObject待ち状態です)
ご確認をお願いします。
(Windows10 22H2 0b176 Rev.1 DEV15)

Gakuto Matsumura - Developer 返信 2022/12/22
そのYaneuraOu_NN-7503.exeは表記が0.00%になった状態で残るということでしょうか?

もりけん - 2140@Jh1MSsFH 返信 2022/12/22
画像のままの状態で残ります。
トップ2だけが変化します。

Gakuto Matsumura - Developer 返信 2022/12/22
73.83%で更新が止まって、2位以下のみ更新されるということですか?
サイクル計算モードをオフにしたらその現象はおきなくなりますか?

難しいかもしれませんが、iniファイルをいただければこちらで再現されるか確認してみます。

Gakuto Matsumura - Developer 返信 2022/12/22
あと、0%と判断した材料は何をもとにしていますか?

もりけん - 2140@Jh1MSsFH 返信 2022/12/22
画像の下の状態(41.46%)で止まったままになります。
%値はタイミングによって変わり、73.83%から減っていき、最後に表示された値のまま残るようです。
サイクル計算モードをオフにすると現象は起きません。
タスクマネージャー及びSysinternals Process Explorerで0%を確認しています。
iniファイルを添付します。よろしくお願いします。

[appended] ini

Gakuto Matsumura - Developer 返信 2022/12/22
再現できなかったけど、閃きました。
多分こうじゃなかろうか!
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20221222-222909.zip

もりけん - 2140@Jh1MSsFH 返信 2022/12/22
現象が全く起きなくなりました!
早急な対応ありがとうございます!

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 不具合 [0b176 Rev.1 DEV9] GPU関連数値の異常
#897
サボり人 - 2137@PPwZ212wPgl0PPt20XmPPfJu0PJZutg 返信 2022/12/14 21:01
お久しぶりです。またお世話になります。

0b176 Rev.1からDEV9に上げてテストしました。
Win11Pro(22H2)
Adrenalin Edition:22.11.2

DEV9ではGPU関連の数値が全て正常に動作していません。
ファンの回転数も固定されており変動しません。
ただし両GPUともグラフは正常に動作します。
A1がVII、A2が6900XTです。

Gakuto Matsumura - Developer 返信 2022/12/14
すみません、こちらのRadeonのテストではとくに問題がでていないので、thilmera7.iniファイルを下さい。

サボり人 - 2137@PPwZ212wPgl0PPt20XmPPfJu0PJZutg 返信 2022/12/14
お送りいたします。

[appended] ini

Gakuto Matsumura - Developer 返信 2022/12/14
原因がわかりました。

60fpsなどの高頻度の場合、0b177 preview で追加したスレッドの同期で、次回の待機が間に合わない問題が発生していたようです。

DEV10として根本的に対処しました。
0chで配信しています。

サボり人 - 2137@PPwZ212wPgl0PPt20XmPPfJu0PJZutg 返信 2022/12/14
確認いたしました。ありがとうございます。

使用率とファン速度は正常になりました。
しかし、温度、ジャンクション温度、周波数、ワット数は現状でも修正されておりません。
ワット数以外の数値は設定でチェックを入れても表示されません。
ワット数はTDPを指定すれば数値は出せますが、TDPを400Wで指定してもかなり低い値になっていますので正しい値ではありませんでした。

Gakuto Matsumura - Developer 返信 2022/12/14
確認ありがとうございます。

TDPからのワット数に関しては、概算であり、正確な数値にはならないのは仕様です。
TDPとワット数は根本的に別のものであるためです。

repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20221214-232729.zip
こちらを起動して出力される「debug_log.GPU.txt」を下さい。
何が動いていて何が動いていないのかの確認をしたいです。

サボり人 - 2137@PPwZ212wPgl0PPt20XmPPfJu0PJZutg 返信 2022/12/14
お送りいたします。

[appended] txt

Gakuto Matsumura - Developer 返信 2022/12/14
何度もすみません。
こちらでもう一度同じものをください。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20221214-234050.zip

関数の呼び出しがそもそもそろっているかの確認です。

サボり人 - 2137@PPwZ212wPgl0PPt20XmPPfJu0PJZutg 返信 2022/12/14
どうぞ。

[appended] txt

Gakuto Matsumura - Developer 返信 2022/12/14
どこで詰まってるのか…

すみません、もう一度お願いします。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20221214-235000.zip

サボり人 - 2137@PPwZ212wPgl0PPt20XmPPfJu0PJZutg 返信 2022/12/14
どうぞ。

[appended] txt

Gakuto Matsumura - Developer 返信 2022/12/15

サボり人 - 2137@PPwZ212wPgl0PPt20XmPPfJu0PJZutg 返信 2022/12/15
どうぞ。

[appended] txt

Gakuto Matsumura - Developer 返信 2022/12/15
多分これでなおるはず!
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20221215-002833.zip
もう一度お願いします。

何度もすみません。

サボり人 - 2137@PPwZ212wPgl0PPt20XmPPfJu0PJZutg 返信 2022/12/15
直りました。ありがとうございます。

ADLをとってくるのは面倒なんですねえ…

[appended] txt

Gakuto Matsumura - Developer 返信 2022/12/15
すみませんでした…

動的な関数の定義を全面的に書き直したので、まず真っ先にそれを疑って、ミスリンクの関数を探してもとくに問題なかったのですが、よくよくエラーをたどってみると、名前の似ている別の定義を本来とは違うところに入れてしまっていました。

地味にクラッシュしない程度に似たものを…

ADLに罪はありません💦

DEV11として出しました。

サボり人 - 2137@PPwZ212wPgl0PPt20XmPPfJu0PJZutg 返信 2022/12/15
お疲れ様です。
アップデートして数値は正常になりましたが、非常に高負荷でフレーム落ちが発生します。
Discordで動画を送ります。

Gakuto Matsumura - Developer 返信 2022/12/15
DEV12にて解決済みを確認。

上記の問題は、盛りに盛ったRadeonのデバッグログのファイル出力がWindows Defenderをフル回転させたため。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

[Closed] 要望 ファンの稼働率のグラフ表示
#895
thil - 2133@gzcx1M/S 返信 2022/12/06 00:43
ファンの稼働率をメモリグラフなどと同様のグラフで表示したいです。

値は
例えば「ファンパーセント」の値をグラフ表示するのはどうでしょうか。

ご検討よろしくお願いいたします。

Gakuto Matsumura - Developer 返信 2022/12/06
お待たせしました。

基本的に、GPUのライブラリからの情報をえるのはシルメラの情報取得の中でもかなり重い部類に入るので、基本的にGPUのライブラリ外から拾えるRPMをグラフ化するものを作りました。
配布チャンネル0chにて、DEV7として配信中です。

これはRPMの最大値を手動指定する形ですが、基本的にデフォルト設定の1500RPMを超える場合はもう100%でいいんじゃないか?と思います…

このへん、どうしても重くなってもいいからパーセンテージの情報を取りたいとか、自動的にRPMのMAX値を保存してほしいとかありましたらご意見下さい。

Gakuto Matsumura - Developer 返信 2022/12/06
配布チャンネル0chは「設定>その他>配布チャネル」を0に指定することで切り替えられます。

thil - 2134@gzcx1M/S 返信 2022/12/07
これで全く問題ありません。
手動指定の方がとても都合が良いです。

ありがとうございました。

thil - 2134@gzcx1M/S 返信 2022/12/07
立て続けの要望になりたいへん恐縮です。

GPUファングラフと同じ形のものを
マザーボードのファンに対しても設置することは可能でしょうか?

ただ、今使っているPCはマザーボードの情報取得に対応していないらしく、「NOT ALIVE」と表示されます。
しかしながら、対応したPCが使えるようになったときにグラフ表示させたいと思い、要望させていただきました。

ご検討のほどよろしくお願いします。

Gakuto Matsumura - Developer 返信 2022/12/09
NOT ALIVEの場合テストにはならないと思いますが、一応作りました。
repo.thilmera.com/pac/thilmera7/test/thilmera7test_build_s64_20221208-235659.zip
0b177 preview - DEV8

thil - 2133@gzcx1M/S 返信 2022/12/09
ご対応ありがとうございます。

NOT ALIVEのままですが
本体の起動、設定画面の確認ができました。
今後、情報取得に対応したPCを入手したときに役立てようと思います。

この度はありがとうございました。

CLOSED : 追記した内容は通常通り管理人に通知されます。

update
返信

*オープンクローズ
 + 
#
thilmera project - forum
フォーラム一覧
t7b - v12.30.0.0
Original - Board v3.4 Revision(http://revision.s22.xrea.com/)
© 2001-2024 Gakuto Matsumura:弦生ささと (thilmera7gmail.com) Privacy Policy